eclipse 换了高版本的 maven 插件后报错:org.apache.maven.archiver.MavenArchiver.getManifest(org.apache.maven.project

eclipse 导入新的 maven 项目时,pom.xml 第一行报错:

org.apache.maven.archiver.MavenArchiver.getManifest(org.apache.maven.project.MavenProject, org.apache.maven.archiver.MavenArchiveConfiguration)

解决办法:

1、Help——>Install New SoftWare

2.

https://otto.takari.io/content/sites/m2e.extras/m2eclipse-mavenarchiver/0.17.2/N/LATEST/

3.按照安装提示,一直 next,重启 eclipse 之后,执行 maven-update project