升级 Spring Boot 2.0 多数据源报错

升级 Spring Boot 2.0 多数据源报错
Spring Boot 从 1.5.x 升级到 2.0,其中有些变化,如果不注意就会跳坑。在多数据源编程方面,从 1.5.x 升级到 2.0,如果不注意其中的变化,就会碰到“jdbcUrl is required with driverClassName.”的错误,本文给出解决办法。

但是在升级到 Spring Boot 2.0 后,一些配置及用法有了变化,如果不小心就会碰到“jdbcUrl is required with driverClassName.”的错误,
jdbcUrl is required with driverClassName.我经过一番努力,查找资料,终于找到了解决办法,在这里分享出来,省得后来者再去查找资料。

解决办法
在配置文件中使用 spring.datasource.jdbc-url,而不是通常使用的 spring.datasource.url。
在配置文件中使用 spring.datasource.driver-class-name,而不是通常使用的 spring.datasource.driverClassName。